The Megaphone

RAMP customers: plugin released for WordPress GUID compatibility

The CF GUID-Fix plugin corrects duplicate GUID values created with versions of WordPress that exhibited a non-unique GUID bug. This has been described in detail via an email to existing customers:

There were certain versions of WordPress that contained a bug that caused the value in the GUID field in the “posts” table of the WordPress database to not be unique for pages and custom post types (the GUID is supposed to be unique). This problem was fixed in WordPress 3.1 (we submitted the patch), but any pages or custom post type content that was created with the version of WordPress that exhibited this bug still may have duplicate GUID values.

In short, if you used WordPress 3.0.x or earlier on your site, run this plugin to fix potential bad data that might prevent RAMP from working correctly. If you started using WordPress with version 3.1 or later then your site should not have this issue.

The GUID fixer can be accessed from your Account page or from the CF GUID-Fix Plugin Page. Click here to directly download CF GUID-Fix.

About the Author

Chris Forgham was a product and QA manager at Crowd Favorite.